Back to top

Reporting bugs or suspected bugs

122 posts / 0 new
Last post
WS Member wsadmin's picture
Reporting bugs or suspected bugs

You are welcome to add bug reports as comments here and we'll respond to them.

We actually manage all development issues over on github so if you're interested in seeing current bug reports or feature requests, take a look over there. If you're development-oriented and/or have a free github account, feel free to comment over there as well.

WS Member WS Member's picture
response ratio

I have seen today (someone told me) that the "is responsive" is no longer present but instead there is a response ratio.
I were disappointed to see that i had a 17/21 reply .
Actually i just replied with a "!" to each of the four message swithour reply and got again a 100% reply.
So it is easy to cheat.
Incidentally of the 4 unsansvered requests 3 were of of people to whom i replied by phone since was a last minute request; the last one was one that send a request, i told him "i cannot confirm that days until 3 days before" and so he started a new thread telling "i have found another accommodation, i no longer need your spce", that of course did not required a reply.
I would like better an option with a checkbox for "i want a reply" and so compute reply ratio only on that messages.

WS Member wsadmin's picture
Aha! You caught me :-) If

Aha! You caught me :-)

If the whole world was responsive and cared like you do there wouldn't be any need for anything like this anyway. We so appreciate your responsiveness. I don't think anybody would think 17/21 would be a bad number, but rather a wonderful one.

The "mark responsive" was used too lightly to work very well. You had to remember "Oh, somebody didn't reply" and then go mark them. Only a very careful person (perhaps with too much time on their hands) would do that religiously. So we wanted to go with something that was based on actual activity, and that's what you see. The calculation and database query was actually quite hard to figure out.

And there's no problem at all with cheating. Anybody who cares enough to cheat is already a great citizen. Anybody who cares about their responsiveness in the first place is just fine.

I'm sure this will evolve.

By the way, the overall responsiveness all all hosts to all messages right now is about 62%.

-Randy

WS Member WS Member's picture
any dealine time to respond

Hi Randy,
In new responsiveness system,is there any time limitation for responding the requests? or one can reply after several months and new assessment system counts it?
If it has a deadline ,how much is it?

thanks

WS Member wsadmin's picture
All the system does is look

All the system does is look to see if there's any response to the *initial* contact in the thread.

* Right now it's only looking at messages since August 15, which is about when reply messages started marking the original as read.
* As time moves on, it will look at the previous year's history

There is no deadline or anything.

The intention here is not to punish or reward anybody, but just to give prospective guests an idea of whether there is a live host on the other end. So it's the 0% and 5% that are the thing to know about, not the 50% or 75% or 100% :)

WS Member WS Member's picture
assume someone got one

assume someone got one request and replied one month ago, and then today got 5 requests for halloween.
the 6th to sent will get a 1 on 6 reply rate.
One should ignore the unanswered messages less than one day old (they add if answered, but do not go to denominator if unanswered).

WS Member wsadmin's picture
I thought about that and may

I thought about that and may consider it as time goes on. The reality is that the vast majority of requests either happen much more slowly than that, or the time that the response rate is wrong is super low. So somebody who never answers will have 1/30. Somebody who always answers and gets a lot of requests will have 25/30 for a few hours. The idea here is to provide representative, useful data based on information we have. It's necessarily an estimate, but my bet is that it's already pretty representative and will increase in value as the days go along. And maybe it will even improve some hosts responsiveness, but I'm not very hopeful about that. The few members who don't answer don't care or aren't connected. The ones who see their responsiveness rating are already our best members and best hosts. Like you, Mr. 21 responses for 21 requests.

WS Member WS Member's picture
Too complicated

I am a great fan of warmshowers. But I find the new design of the website far too complicated. I worry that the community may be restricted to those who are computer experts, and many of the rest of us will give up in frustration. John Butters

WS Member WS Member's picture
Following Up

Dear John and Jane

Let me know what you find more complicated now. versus before, so we can work to simplify it.  It was certainly not our intention to make things more complex, and I know we can make things more simple if you can let us know which changes in particular your finding challenging.  

Thank you- Seth

WS Member WS Member's picture
Meta-Bug

So I posted in this thread once and signed up to be notified of new responses via email. It seems that I'm not able to unsubscribe from those notifications. I can click on the link in the email and get the "Your comment follow-up notification for this post was disabled. Thanks." message, but the emails keep coming anyway. Not a huge deal, but still a bug. Thanks for looking into this.

WS Member wsadmin's picture
Hi Harald - I remember this

Hi Harald - I remember this being a bug in the comment_notify module, but thought it was resolved a couple of years ago.

What's going on is you posted in this thread several times... and each one subscribed you for more :-) If you had faithfully hit that unsubscribe two more times I think you would have been off, but I can't guarantee it.

Anyway, I'll unsubscribe you manually now (after you get notified about this message).

-Randy

WS Member WS Member's picture
Ah, I see. Thanks for fixing

Ah, I see. Thanks for fixing this!

Unregistered anon_user's picture
Interesting language bug

Or maybe its just me.

When I reply to a post my language sometimes changes. Had it swap to Portuguese and Chinese today. Probably depending on whose post I answered. No problem to swap back but still. :)

Cheers
Mikael

WS Member wsadmin's picture
Notification language is the problem

Yes, this is a bug. When you get notified, the notification sends out links using the language of the poster.

I don't think we'll probably fix this anytime soon, as it's a bug in the underlying Drupal implementation.

Thanks for the report though!
-Randy
Warmshowers.org webmaster

WS Member WS Member's picture
New posts

Hi
Before it was possible to filter to visible only new posts from forum start page. Where is the button now?

WS Member wsadmin's picture
Tabs on the top give forum view options

There are some tabs on top - they're easy to miss.

WS Member WS Member's picture
Yes, I know them. Today they

Yes, I know them. Today they are again visible. Yesterday something was wrong somewhere. :)

WS Member WS Member's picture
Host reply to requester via email posted blank message

Hi - I responded to a hosting request directly by email but did not note the "Please reply above this line" notation and replied AFTER the included text of the original email as per my usual email protocol. As a result, my potential guest received a blank email.

How "baked in" is that formatting requirement? I wonder how many responses have been lost from being mis-formatted this way?

WS Member wsadmin's picture
Most email reply systems work

Most email reply systems work like this, and we've never had a concern a out it before. I myself prefer to just blank out any of the craft below the message and not make the system try to figure out what's important. In other words, you can just delete everything before you start typing and it will work fine.

-Randy
Warmshowers.org webmaster

WS Member WS Member's picture
Profile name not updated

If someone changes his/her profile name (which will definitely happen during time), it can be that the same user (even in one topic) shows up with different names, but it is the same person (picture is the same). This is a low bug.

When loading the page we find the object/event ID in the DB which is unique and then show the name that corresponds to it (which can change during time), like we apparently do for the picture that comes with it...

Example:
https://www.warmshowers.org/node/63183
Annefiets = Anne Potters

Regards, Martin

WS Member wsadmin's picture
It's not that things aren't

It's not that things aren't updated, it's that the username is used some places and the full name in others. Our long term goal is to always use the full name display for logged in users and not show any info to users who aren't logged in. We'll get there :)

-Randy
Warmshowers.org webmaster

WS Member WS Member's picture
What do you want?

Hi,

It is not very clear to me what you expect to be honest... Do you want people to report bugs by adding a Post Reply? I can imagine that you:

Either want us to go to https://github.com/warmshowers/Warmshowers.org/issues and report the bugs there. In that case be very specific in your message to prevent replies as above.

Or you want the bug to be reported on the WS-website first to be able to reply and then forward the bug your selves...? But then it would be more logical to have a New topic functionality as you use for feature requests...?

Regards, Martin

WS Member wsadmin's picture
Best is reporting with full

Best is reporting with full info on github. But not everyone is up for that, so we're happy to read issues here and via the contact form.
-Randy

WS Member WS Member's picture
email replies fail

Sometimes when I reply to a message notification, the reply fails instead of going through. Other times email replies go through, although if a message fails then no amount of resending it seems to help. Sending from Android mail app. Screenshots available.

WS Member wsadmin's picture
Please be more specific about

Please be more specific about the problem you're having. Please provide complete details, including what you were doing, what you expected, and what happened instead. Send the information to wsl@warmshowers.org with a bounce email if you got a bounce.

And remember that you can always log into the site to reply to any message there.

Thanks,
-Randy
Warmshowers.org webmaster

WS Member WS Member's picture
Sent.

Sent.

WS Member WS Member's picture
attach file to a feedback

Hi Randy,

I attached a kml or kmz file ( I am not sure which one) to a feedback, 3 month ago. but when I checked it today it was gone.
Is it a bug?

thank you

WS Member wsadmin's picture
Sorry, I don't know what

Sorry, I don't know what might have happened. I'm traveling and don't have a way to look at it either. But when you report something like this please provide a link to the feedback node and the name of the file. Otherwise it's impossible to debug. - Randy

WS Member WS Member's picture
just for your information

sorry to bother you and I hope you have a great trip.

here is the link .( notice the "P.S." item in the feedback that I gave to Thierry.)

https://www.warmshowers.org/user/34565/feedback

by the way, its not a big deal . I said that just for your information. I thought it may be better that you know the history of the problem if it happens again.

thanks a lot

WS Member WS Member's picture
providing feedback bug

Hi!
I have such a problem since yesterday.

When I'm trying to give a feedback to two different guys in the end feedback always goes for me.
When writing a feedback in he top part of screen is username of a right person, but then after posting or previewing it goes to me.
Need help!

WS Member wsadmin's picture
Visit the member's page to start

Hi Wojciech, I just left feedback for you with no trouble... I think the answer is to visit the member's page *first* and click the "Provide Feedback" link on the right side of their page.

WS Member WS Member's picture
this is exactly what I was

this is exactly what I was doing. It used to works in the past.

I solve the problem already: when posting a feedback (of course visiting someone's profile) I have to change from my username to my host's username. I have to do it second time after viewing my feedback, so for me it's definitely a bug.

WS Member wsadmin's picture
A browser or browser extension may have memorized your username

It sounds to me like you have a form autofill feature turned on in your browser and it has memorized your username :-) Those things cause a lot of trouble!

WS Member WS Member's picture
might be. Thanks a lot!

might be. Thanks a lot!

WS Member WS Member's picture
RSS Feeds

Hi,
it seems like I cant read your RSS feeds since a long time back. I use thunderbird and firefox. It looks like you are using https:// for the feed-urls but dont actually do any encryption of them ? When I look at the network traffic there are complaints about invalid CA when trying

https://www.warmshowers.org/forums/region-and-country-specific-information/feed

but not when trying

https://www.warmshowers.org/forums/region-and-country-specific-information

/TC

WS Member wsadmin's picture
The only RSS feed we've ever

The only RSS feed we've ever actually supported is the main one (listed in site headers), https://www.warmshowers.org/rssfeed

However, the URL you suggest (https://www.warmshowers.org/forums/region-and-country-specific-information/feed) loads fine on Chrome, with no complaints, no issues if you examine the "padlock" info.

On what browser and OS are you getting "Invalid CA"?

Happy to help you resolve this!

-Randy
Warmshowers.org webmaster

WS Member WS Member's picture
Hi Randy, that's what you get

Hi Randy,
that's what you get when you use a NSA approved browser :-)

I use thunderbird and firefox on Linux. The invalid CA I got when I used curl and wireshark so that might be due to curl not having comodo.

I sent you the "proof" as png.

My best guess is that the rss is not served within the SSL realm of the webserver, maybe something in drupal.

/TC

WS Member wsadmin's picture
Just for future reference,

Just for future reference, Tomas was running Linux and had to update his machine's certstore. Many Linux distros are not terribly good at keeping up with this stuff. It appears that an obscure bug made this fail in the "feed" URLs and not other places.

WS Member WS Member's picture
Unable to send e-mail. Please contact the site administrator

I do get a message every time I put an update on a forum post saying that there is a problem: Unable to send e-mail. Please contact the site administrator if the problem persists.

https://www.warmshowers.org/content/tips-cycle-trip-amsterdam-copenhagen#comment-13473

Not sure whether the guy who reads it does get an email, but at least he responds quite prompt...

Regards, Martin

WS Member WS Member's picture
P.S. the message did not show

P.S. the message did not show up when posting here...

WS Member wsadmin's picture
Thanks for the report!

I sure appreciate you reporting this problem and being completely specific about where it occurred. I took a look, and what happened is that the original poster of that post has deleted his account, so there's no email associated with it, but the module that tries to notify everybody is trying to notify a blank email.

Thanks so much,
-Randy
Warmshowers.org Webmaster

WS Member WS Member's picture
Duplicate message in inbox

I was trying to figure out why my response rate was less than 100% even though I'd responded to everyone and discovered that one guest's initial message was duplicated in my inbox. It appears to be identical and has the same timestamp. I don't recall seeing the duplicate at the time the message originally appeared; I think I would have noticed it. Bug?

WS Member wsadmin's picture
Most likely not a bug

I've seen this before, but mostly in comment posts. People hit the submit button twice, or hit the browser back button and hit submit again.

In your email notifications, at least on gmail-like systems, you'd never know the difference because the title is the same and they get lumped together.

Thanks so much for caring about your responsiveness!

WS Member WS Member's picture
Makes sense to me. Thanks!

Makes sense to me. Thanks!

WS Member WS Member's picture
picture upload

why is it so hard to upload a profile picture?
i am trying to change my profile photo after a year or more and i totaly forgot what a pain it was the first time i was doing it.
choose image from pc? yes
uploaded? no
hold shift + refresf? no success
repeat few times? no success

why is this still a problem?

WS Member wsadmin's picture
Some people have the problem

Some people have the problem of not remembering that they have to finish the edit of their profile by clicking the "Save" button at the bottom of the edit form.

If you can't get it to do what you want, feel free to email the photo to us at wsl@warmshowers.org and we'll put it on your account. Right now I see this:

-Randy Fay
Warmshowers.org Webmaster

WS Member WS Member's picture
i remembered to push save

i remembered to push save each time but all it did was delete previous picture and leaving profile photo empty after uploading new one. then suddenly - it's threre. now i sound crazy...but that's what happened.
anywho, thaks for your answer.

WS Member WS Member's picture
Strange return date

It is a bug in:

https://www.warmshowers.org/user/90267

or he is joking ? I knew you cannot set as a return more than one day apart.

or it is the 32 bit bug ?

WS Member WS Member's picture
No bug

It's not a bug. We changed the return date so that members who did not really know when they would return or be available again could set the date as far into the future as they wished.

It's not a perfect solution to the problem but it seems to help.

Mark

WS Member WS Member's picture
Not receiving e-mail notification of feedback anymore

I wrote this on the Wish list (where others confirmed that there is a problem), but I probably should have mentioned it here. Notification of messages works, and even when I give feedback I get notified of that by mail. But not when my guest gave feedback for me.

Edit: Randy now wrote in the thread that I had posted on the Wish List that the problem has been solved. Thanks!

WS Member WS Member's picture
address and map location

Hello

I wonder why this member is shown in Syracuse, NY.
His address indicates Anchorage AK.

https://www.warmshowers.org/user/21114

Thanks

Pages